Qubes OS 3.2 – Ein Hands-On

Diesmal, ganz ungewöhnlich, ein Hands-on Beitrag von mir. Mit anderen Worten, ein kleiner Versuch mit dem System zu spielen. Und zwar dieses mal Qubes OS, ein Linux System mit einem Haufen VMs, die in Xen irgendwie verbandelt sind und ein ziemlich komisch anmutendes Konstrukt ergeben, wenn man sich das Ding mal anschaut. Die Idee an sich, super – meine Graphikkarte, Nvidia.

Wie dem auch sei, warum soll mich eine Karte davon abhalten, mit einem System zu spielen? LiveCD via DriveDroid an den PC, SSD2go von Angelbird an den Laptop und mal eingeschaltet. Es begrüßt der Anaconda Installer. Wir haben es offensichtlich mit irgendwas Yum-Benutzendem zu tun – mitunter Fedora.

Doch da der Installer im Textmodus kläglich scheitert, klemme ich die USB Platte an einen anderen Rechner und lasse diesen arbeiten. Nach der Installation geht’s wieder zurück zu Meinem um festzustellen, dass wir zumindest am USB Bildschirm eine Textconsole haben. Grausam langsam, aber immerhin eine Konsole mit Login-Prompt, der als Draufgabe sogar funktioniert.

Frisch eingeloggt befinden wir uns am Host System, dem Dom0. Klassischerweise sollte da die NVidia Unterstützung rein, aber so einfach ist das natürlich nicht: Es fehlen Kernel-Headers, GCC und andere Developer-Pakete. qubes-dom0-update sollte es möglich machen – tut’s aber nicht ganz, da erstmal die Firewall VM mit der Netzwerk-VM Probleme hat, da diese ein PCI Device nicht findet.

Nach dem ersten Na-Toll Erlebnis konnte ich die Netzwerk-VM davon überzeugen, dass sie doch die vorhandene Netzwerkkarte zu nutzen habe – wir erinnern uns: Installation auf anderer Hardware. Der Befehl dazu ist ‚qvm-pci sys-net -d ‚ und ‚qvm-pci sys-net -a

Um die ganzen Abhängigkeiten wollte ich mich nicht kümmern müssen – also folgte ein simpler Reboot sowie ein qubes-dom0-update um das System mal halbwegs auf Stand zu bringen nebst einer Installation von gcc, kernel-devel, kernel-headers und kmod. Aus Faulheit gab’s dann noch das böse NVidia Driver-Gedöns auf USB Stick.

Nach dem Compile und der Option Xen zu ignorieren, folgte ein ‚depmod -a‘ und das nvidia-Modul war zumindest mal im System und ich konnte den reboot wagen.

Author:

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Notify me of followup comments via e-mail. You can also subscribe without commenting.