Die OQO Odyssee – Teil 4

Dieser Artikel ist ein Teil der OQO Odyssee – Serie. Die vorigen Artikel befinden sich hier, hier und hier.

Wenn ihr euch – genau wie ich – gedacht habt, dass der Rest nun ein simples Zuckerschlecken wird, dann habt ihr euch geschnitten. Der OQO hat noch ein paar Überraschungen zu bieten. Aber alles der Reihe nach.

Ich beginne meinen Bericht am Besten beim Kernel, welcher mich schon vor das erste Rätsel gestellt hatte, da ich z.B. keine LAN Karte beim Listen des PCI-Bus gefunden hatte. Kurz nachgedacht und dann kam auch schon der Funke: USB

Also noch schnell einen Blick auf den USB Bus werfen um zu sehen, was sich dort verbirgt. Um es einfach zu halten, klemme ich das Docking-Cable auch gleich dran um wenigstens alle Gerätschaften zumindest einmal zu sehen:

Bus 003 Device 002: ID 1557:0002 OQO model 01 WiFi interface
Bus 003 Device 003: ID 1557:0003 OQO model 01 Bluetooth interface
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 1557:7720 OQO model 01+ Ethernet
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Na klasse. Die Infos sind genauso zu gebrauchen wie die Hilfe zu Windows. Also bleibt mir nur der Weg der Recherche, was die Jungs nun wirklich verbaut haben. Die Netzwerkkarte entpuppte sich schließlich als ASIX AX8817X basierende Karte, das WLAN als Atmel AT76C505A USB WiFi.

Mit diesen Infos bewaffnet ging es mal an den Kernel und schließlich an den Datentransfer, welcher natürlich sämtliche Berechtigungen berücksichtigen und eben übertragen musste. Meine Lösung sieht wie folgt aus:

tar cpf – * | ssh oqo „(cd /mnt/gentoo/boot; tar xvpf -)“

Ich packe auf meinem Laptop also die Dateien in ein Tar-Archiv und schicke das über SSH an den OQO, welcher die Dateien in Empfang nimmt und sie gleich nach dem Wechsel in das richtige Verzeichnis entpackt ohne lange temporäre Dateien zu schreiben.

Achtung Falle: Wenn man nicht aufpasst, werden dabei nicht alle Dateien korrekt geschrieben und das endet wie bei mir fatal. Ich hatte noch ein paar Daten von meinem fehlgeschlagenen Experiment mit dem Bootstrap herumliegen und einfach nur das Archiv drübergebügelt, gebooted und festgestellt, dass bei einem Emerge das System Selbstmord begeht und sämtliche Pakete rausrupft, in der fixen Überzeugung das Richtige zu tun. Also am Besten kurz das Filesystem neu anlegen bevor man den Stunt macht…

Nach dem Transfer starte ich den OQO und oh Wunder, das Ding booted einmal bis zum klassischen Login-Prompt und kann mich als Draufgabe sogar einloggen. Also kurz den SSHd angeworfen und die Konfiguration fortgesetzt um zu sehen was nun tatsächlich läuft. WLAN und ACPI gehörten jedoch derzeit definitiv nicht dazu.

Nach einigen lauteren Flüchen stoße ich bei meiner Suche auf ein Paket mit dem hoffnungsvollen Namen net-wireless/at76c503a, welches sich dann doch irgendwie als nicht ganz das was ich suche herausstellte…

Mein nächster Versuch Treiber zu finden geht in Richtung diverser Mailinglisten. Vielleicht kann ich ja doch noch den einen oder anderen Tipp bekommen. Ich halte euch auf jeden Fall am Laufenden.

Author:

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Notify me of followup comments via e-mail. You can also subscribe without commenting.